Selling your classic car? It's FREE to list your car on Honest John Classics | No thanks

Toyota Voxy - Toyota Misfire And White Smoke On Cold Starting

Hi Everyone

I would like to post my issue here and I am not sure if this is the right place for it as this is my first time I post threads on this forum and hopefully I get some help from you members.

My issue is that I have just rebuilt a 2004 Toyota Voxy engine (Engine Code: 1AZ-FSE) 2.0L Petrol Automatic and am having the following problems with the car when I start it:

1/ Car rev too high (2000RPM) on start up
2/ Car starts blowing lots of white/grey smoke on cold start and clears away after running for 2-3 minutes and also when I put My hand in the smoke it feels a little bit greasy.
3/ Car also has got some misfire that can be felt when listening to the exhaust pipe blowing intermittently.
4/ The engine gets really hot real quick and the fan keeps coming on very frequently but I think this might be due to some air blockage in the cooling system or some leak in the radiator.
5/ The oil dipstick kind of smells of petrol.
6/ No fault codes given when scanned with my Autel MaxiSys Pro MS908P.

So my questions to the experts here are:

Do you think this is an injector leak issue? or a Vacuum leak because I suspect some bad intake manifold gaskets?
The engine sound is smooth and all the valve stem seals, piston rings, con rod bearings, head gasket and timing chain replaced and the crack shaft was regrinded by professionals in the rebuild process . And also the engine was thoroughly cleaned before assembling it.

Your quick replies will be highly appreciated as I am really not sure where to start with fixing this engine.

Thanks.

Comments

Omar Farooq    on 30 August 2019

Did you manage to get any answers elsewhere?

Thinking of getting the same car, maybe a 2007, but older shape or try to get the 2007 shape. Is it worth it, reliability wise?

Add a comment

 

Ask Honest John